The IRIS ExplorerTM Environment





Previous : Contents : Next

Starting IRIS Explorer

To start IRIS Explorer, click on the IRIS Explorer icon in the IRIS Explorer folder on the Start Menu (which you can find by clicking Start, then pointing to Programs).

The following three windows will appear:

  • Module Librarian
  • Map Editor
  • Log window
An annotated example is shown below. If your copy of IRIS Explorer has been previously used, the layout might be slightly different since IRIS Explorer stores the layout as it closes. Controlling how the interface looks is achieved via the View menu. If any of the windows do not appear, ensure that window name has a tick beside it in the View menu. Note that if the Map Editor window is maximised, access to the Module Librarian can be achieved by pressing the relevant button on the Windows taskbar (which is normally along the bottom of the screen).

Figure 3.1: The IRIS Explorer Interface




The Module Librarian

The Module Librarian is the repository for modules and maps. There are a number of pre-defined categories simplifying the task of finding a particular module or map. It is possible to change or remove the existing categories as well as add your own. To examine the contents of a category, click on the "+" button with the left mouse button. Click on the "-" button to compress it.

The shelf is a special category that appears as an area where you can place frequently used maps and modules, giving instant access to them when required. You can place a module on the shelf by dragging it from the main window of the Module Librarian and dropping it in the shelf area.

Figure 3.2: The Module Librarian Interface




The Map Editor

The Map Editor is the main window in the IRIS Explorer interface. It is the area for creating and editing IRIS Explorer maps. Modules are selected from the Module Librarian, and manipulated in the Map Editor to create the required application. The File menu on the Map Editor contains the Exit option which is used to exit IRIS Explorer.

Figure 3.3: The Map Editor Interface


The Log Window

Some modules can be configured to produce messages which are displayed in the Log Window. A log window can also be started for an individual module by clicking with the right-hand mouse button on the module and selecting Show Log. By selecting Log Window output with the mouse and then clicking the right-hand mouse button, you can copy or cut and paste the text into other applications.

Figure 3.4: The Log Window



Previous : Contents : Next
© The Numerical Algorithms Group Ltd. Oxford, UK. 2000

Website Feedback

If you would like a response from NAG please provide your e-mail address below.

(If you're a human, don't change the following field)
Your first name.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions.
Image CAPTCHA
Enter the characters shown in the image.